Back to overview
Downtime

Panel has some issues

Feb 18 at 07:29am UTC
Affected services
Panel

Resolved
Feb 18 at 06:15pm UTC

We resolved the issue. And we will implement a prevention for it soon. Now it should start to run normally again.

Updated
Feb 18 at 04:21pm UTC

We have investigated the issue. We are currently working on a fix for it.

Created
Feb 18 at 07:29am UTC

We detected an issue with our current system. Under investigation.