Back to overview
Degraded

CosmeticsMod Connection Issues

Mar 04, 2026 at 06:58am UTC
Affected services
CosmeticsMod Connection

Updated
Mar 04, 2026 at 04:00pm UTC

Dashboard Login via MoreCosmetics Mod is now possible again.

Created
Mar 04, 2026 at 06:58am UTC

Login via MoreCosmetics Mod and update Cosmetics via dashboard are currently unavailable.
Library ingame still works normally.